// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$").unwrap();
let string = "John Doe Due
José Antonio Domínguez Cigüeña
Domingo Del Campo Retorno García
Angel Manuel Rodrígues Vermúdez";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}