$re = '/^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$/m';
$str = 'John Doe Due
José Antonio Domínguez Cigüeña
Domingo Del Campo Retorno García
Angel Manuel Rodrígues Vermúdez';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);