re = /^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$/m
str = 'John Doe Due
José Antonio Domínguez Cigüeña
Domingo Del Campo Retorno García
Angel Manuel Rodrígues Vermúdez'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end