const regex = /^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$', 'gm')
const str = `John Doe Due
José Antonio Domínguez Cigüeña
Domingo Del Campo Retorno García
Angel Manuel Rodrígues Vermúdez`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}