import re
regex = re.compile(r"^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$", flags=re.MULTILINE)
test_str = ("John Doe Due\n"
"José Antonio Domínguez Cigüeña\n"
"Domingo Del Campo Retorno García\n"
"Angel Manuel Rodrígues Vermúdez")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")