# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(attn|co|dba|fka|dept)\b.*//gm;t' <<< "bobs burgers dba bobs
100 Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 attn Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 Oceanside depth drive
nashville, tn fka 37204"