#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(attn|co|dba|fka|dept)\b.*"
Local $sString = "bobs burgers dba bobs" & @CRLF & _
"100 Oceanside drive" & @CRLF & _
"nashville, tn 37204" & @CRLF & _
"" & @CRLF & _
"bobs burgers dba bobs" & @CRLF & _
"100 attn Oceanside drive" & @CRLF & _
"nashville, tn 37204" & @CRLF & _
"" & @CRLF & _
"bobs burgers dba bobs" & @CRLF & _
"100 Oceanside depth drive" & @CRLF & _
"nashville, tn fka 37204"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)