import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(attn|co|dba|fka|dept)\\b.*";
final String string = "bobs burgers dba bobs\n"
+ "100 Oceanside drive\n"
+ "nashville, tn 37204\n\n"
+ "bobs burgers dba bobs\n"
+ "100 attn Oceanside drive\n"
+ "nashville, tn 37204\n\n"
+ "bobs burgers dba bobs\n"
+ "100 Oceanside depth drive\n"
+ "nashville, tn fka 37204";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}