const regex = /\b(attn|co|dba|fka|dept)\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(attn|co|dba|fka|dept)\\b.*', 'gm')
const str = `bobs burgers dba bobs
100 Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 attn Oceanside drive
nashville, tn 37204
bobs burgers dba bobs
100 Oceanside depth drive
nashville, tn fka 37204`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);