package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:(?:(?:f|ht)tps?:\/\/)|(?:www\.))[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]`)
var str = `https://www.example.com
http://www.example.com
ftps://www.example.com
ftp://www.example.com
https://example.com
http://example.com
ftps://example.com
ftp://example.com
www.example.com
https://www.example.com?u=123&txt=abc#anchor
http://www.example.com#:~:text=hightlightfromhere,tohere
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}