#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})"
Local $sString = "BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")