import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<a1>BARC)\\|(?<a2>.{3})\\|(?<a3>010)\\|(?<a4>U7)\\|(?<a5>[A-Z]{2}[0-9]{2})\\|(?<a6>.{4})\\|(?<a7>.{4})\\|(?<a8>.)\\|(?<a9>\\d{10})\\|(?<a10>[A-Z]{9})";
final String string = "BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}