package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})`)
var str = `BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}