const regex = /(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<a1>BARC)\\|(?<a2>.{3})\\|(?<a3>010)\\|(?<a4>U7)\\|(?<a5>[A-Z]{2}[0-9]{2})\\|(?<a6>.{4})\\|(?<a7>.{4})\\|(?<a8>.)\\|(?<a9>\\d{10})\\|(?<a10>[A-Z]{9})', '')
const str = `BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}