use strict;
my $str = 'BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX';
my $regex = qr/(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}