// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?<a1>BARC)\|(?<a2>.{3})\|(?<a3>010)\|(?<a4>U7)\|(?<a5>[A-Z]{2}[0-9]{2})\|(?<a6>.{4})\|(?<a7>.{4})\|(?<a8>.)\|(?<a9>\d{10})\|(?<a10>[A-Z]{9})").unwrap();
let string = "BARC|P2E|010|U7|US50|USHC|L2XX|B|0058451938|XXXXXXXXX";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}