import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<id>\\w+)(?:\\|(?:type=(?<type>\\w+)|order=(?<order>\\w+)|num=(?<num>\\d+)|status=(?<status>\\w+)|\\w+=\\w*))*\\|?$";
final String string = "1|order=asc|type=1\n"
+ "1\n"
+ "1|order=asc|type=1\n"
+ "1|type=1|order=asc\n"
+ "1|type=1|type=2|order=asc\n\n"
+ "1|num=34|type=1|type=2|order=asc|num=14|status=done\n"
+ "1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value\n"
+ "1|num=34|type=1|type=2|order=asc|num=14|status=done|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}