import re
regex = re.compile(r"^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)|\w+=\w*))*\|?$", flags=re.MULTILINE)
test_str = ("1|order=asc|type=1\n"
"1\n"
"1|order=asc|type=1\n"
"1|type=1|order=asc\n"
"1|type=1|type=2|order=asc\n\n"
"1|num=34|type=1|type=2|order=asc|num=14|status=done\n"
"1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value\n"
"1|num=34|type=1|type=2|order=asc|num=14|status=done|")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")