re = /^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)|\w+=\w*))*\|?$/m
str = '1|order=asc|type=1
1
1|order=asc|type=1
1|type=1|order=asc
1|type=1|type=2|order=asc
1|num=34|type=1|type=2|order=asc|num=14|status=done
1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value
1|num=34|type=1|type=2|order=asc|num=14|status=done|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end