const regex = /^(?<id>\w+)(?:\|(?:type=(?<type>\w+)|order=(?<order>\w+)|num=(?<num>\d+)|status=(?<status>\w+)|\w+=\w*))*\|?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<id>\\w+)(?:\\|(?:type=(?<type>\\w+)|order=(?<order>\\w+)|num=(?<num>\\d+)|status=(?<status>\\w+)|\\w+=\\w*))*\\|?$', 'gm')
const str = `1|order=asc|type=1
1
1|order=asc|type=1
1|type=1|order=asc
1|type=1|type=2|order=asc
1|num=34|type=1|type=2|order=asc|num=14|status=done
1|num=34|type=1|type=2|order=asc|num=14|status=done|unknown=value
1|num=34|type=1|type=2|order=asc|num=14|status=done|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}