use strict;
my $str = 'De: Ultimo Test test@test.com
Información:
Nombre: Ultimo Test
Email: test@test.com
Empresa: Ataway
Teléfono: 978505752
Puesto: Manager';
my $regex = qr/Nombre: (?<Nombre>.+)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}