re = /Nombre: (?<Nombre>.+)/i
str = 'De: Ultimo Test test@test.com
Información:
Nombre: Ultimo Test
Email: test@test.com
Empresa: Ataway
Teléfono: 978505752
Puesto: Manager'
# Print the match result
str.match(re) do |match|
puts match.to_s
end