// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)Nombre: (?<Nombre>.+)").unwrap();
let string = "De: Ultimo Test test@test.com
Información:
Nombre: Ultimo Test
Email: test@test.com
Empresa: Ataway
Teléfono: 978505752
Puesto: Manager";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}