$re = '/Nombre: (?<Nombre>.+)/i';
$str = 'De: Ultimo Test test@test.com
Información:
Nombre: Ultimo Test
Email: test@test.com
Empresa: Ataway
Teléfono: 978505752
Puesto: Manager';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);