using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\((?:(?!\[\().)*?\)\]";
string substitution = @"";
string input = @"begin [(Mary [(had [(a )]lil' [(lamb [(whose [(fleece )])])])])]was [(white [( as )])]snow
1 2 3 3 3 4 5 5 4 3 2 1 1 2 2 1
begin [(Mary [(had lil' [(lamb [(whose )])])])]was [(white )]snow
1 2 3 4 4 3 2 1 1 1
begin [(Mary [(had lil' [(lamb )])])]was snow
1 2 3 3 2 1
begin [(Mary [(had lil' )])]was snow
1 2 2 1
begin [(Mary )]was snow
1 1
begin was snow
begin was snow
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}