import Foundation
let pattern = #"\[\((?:(?!\[\().)*?\)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
begin [(Mary [(had [(a )]lil' [(lamb [(whose [(fleece )])])])])]was [(white [( as )])]snow
1 2 3 3 3 4 5 5 4 3 2 1 1 2 2 1
begin [(Mary [(had lil' [(lamb [(whose )])])])]was [(white )]snow
1 2 3 4 4 3 2 1 1 1
begin [(Mary [(had lil' [(lamb )])])]was snow
1 2 3 3 2 1
begin [(Mary [(had lil' )])]was snow
1 2 2 1
begin [(Mary )]was snow
1 1
begin was snow
begin was snow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)