$re = '/\[\((?:(?!\[\().)*?\)\]/m';
$str = 'begin [(Mary [(had [(a )]lil\' [(lamb [(whose [(fleece )])])])])]was [(white [( as )])]snow
1 2 3 3 3 4 5 5 4 3 2 1 1 2 2 1
begin [(Mary [(had lil\' [(lamb [(whose )])])])]was [(white )]snow
1 2 3 4 4 3 2 1 1 1
begin [(Mary [(had lil\' [(lamb )])])]was snow
1 2 3 3 2 1
begin [(Mary [(had lil\' )])]was snow
1 2 2 1
begin [(Mary )]was snow
1 1
begin was snow
begin was snow
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;