# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\((?:(?!\[\().)*?\)\]"
test_str = ("begin [(Mary [(had [(a )]lil' [(lamb [(whose [(fleece )])])])])]was [(white [( as )])]snow\n"
" 1 2 3 3 3 4 5 5 4 3 2 1 1 2 2 1\n"
"begin [(Mary [(had lil' [(lamb [(whose )])])])]was [(white )]snow\n"
" 1 2 3 4 4 3 2 1 1 1\n"
"begin [(Mary [(had lil' [(lamb )])])]was snow\n"
" 1 2 3 3 2 1\n"
"begin [(Mary [(had lil' )])]was snow\n"
" 1 2 2 1\n"
"begin [(Mary )]was snow\n"
" 1 1\n"
"begin was snow\n"
"begin was snow\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.