const regex = /^(איןטקסט\:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(איןטקסט\\:)', 'gm')
const str = `איןטקסט:שם הערך איןטקסט`;
const subst = `איןטונס:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);