# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^A-Za-z0-9_.-]+/_/gm;t' <<< "joe/bloggs@example.org"