const regex = /[^A-Za-z0-9_.-]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^A-Za-z0-9_.-]+', 'gm')
const str = `joe/bloggs@example.org`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);