import Foundation
let pattern = #"[^A-Za-z0-9_.-]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"joe/bloggs@example.org"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)