use strict;
my $str = 'joe/bloggs@example.org';
my $regex = qr/[^A-Za-z0-9_.-]+/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";