$re = '/[^A-Za-z0-9_.-]+/m';
$str = 'joe/bloggs@example.org';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;