package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^A-Za-z0-9_.-]+`)
var str = `joe/bloggs@example.org`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}