using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\W+(?:\w+\W+){0,5}CNC\b|\bCNC\W+(?:\w+\W+){0,5}(\d+)";
string input = @"the number of CNC machines equalled 5
Here some additional samples of what I want to match ""CNC operators numbering 12"" and the reverse like ""There are 12 qualified CNC operators on site""
Basically any number within a 6 word count of the key phrase. –";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}