// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\W+(?:\w+\W+){0,5}CNC\b|\bCNC\W+(?:\w+\W+){0,5}(\d+)").unwrap();
let string = "the number of CNC machines equalled 5
Here some additional samples of what I want to match \"CNC operators numbering 12\" and the reverse like \"There are 12 qualified CNC operators on site\"
Basically any number within a 6 word count of the key phrase. –";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}