re = /(\d+)\W+(?:\w+\W+){0,5}CNC\b|\bCNC\W+(?:\w+\W+){0,5}(\d+)/m
str = 'the number of CNC machines equalled 5
Here some additional samples of what I want to match "CNC operators numbering 12" and the reverse like "There are 12 qualified CNC operators on site"
Basically any number within a 6 word count of the key phrase. –'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end