import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\W+(?:\\w+\\W+){0,5}CNC\\b|\\bCNC\\W+(?:\\w+\\W+){0,5}(\\d+)";
final String string = "the number of CNC machines equalled 5 \n"
+ " Here some additional samples of what I want to match \"CNC operators numbering 12\" and the reverse like \"There are 12 qualified CNC operators on site\" \n"
+ " Basically any number within a 6 word count of the key phrase. –";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}