import re
regex = re.compile(r"(\d+)\W+(?:\w+\W+){0,5}CNC\b|\bCNC\W+(?:\w+\W+){0,5}(\d+)", flags=re.MULTILINE)
test_str = ("the number of CNC machines equalled 5 \n"
" Here some additional samples of what I want to match \"CNC operators numbering 12\" and the reverse like \"There are 12 qualified CNC operators on site\" \n"
" Basically any number within a 6 word count of the key phrase. –")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")