# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*"[^,]*),([^,]*".*)/\1 \2/gm;t' <<< "-1299-5,\"XXX,XXXX\",trft,4,0,10800"