// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(.*"[^,]*),([^,]*".*)"#).unwrap();
let string = "-1299-5,\"XXX,XXXX\",trft,4,0,10800";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}