use strict;
my $str = '-1299-5,"XXX,XXXX",trft,4,0,10800';
my $regex = qr/(.*"[^,]*),([^,]*".*)/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";