re = /(.*"[^,]*),([^,]*".*)/m
str = '-1299-5,"XXX,XXXX",trft,4,0,10800'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result