# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*\[.*[KQA].*//gm;t' <<< "|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|ABC- shows [ 8d 9h ]|
|ABC- shows [ Qd 9h ]|"