$re = '/^.*\[.*[KQA].*/m';
$str = '|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|ABC- shows [ 8d 9h ]|
|ABC- shows [ Qd 9h ]|';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;