#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*\[.*[KQA].*"
Local $sString = "|dart24356- shows [ 8d 9h ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Kd Kh ]|" & @CRLF & _
"" & @CRLF & _
"|dart24356- shows [ Qc Ac ] |" & @CRLF & _
"" & @CRLF & _
"|ABC- shows [ 8d 9h ]|" & @CRLF & _
"" & @CRLF & _
"|ABC- shows [ Qd 9h ]|"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)