package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\[.*[KQA].*`)
var str = `|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|ABC- shows [ 8d 9h ]|
|ABC- shows [ Qd 9h ]|`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}