import Foundation
let pattern = #"^.*\[.*[KQA].*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|ABC- shows [ 8d 9h ]|
|ABC- shows [ Qd 9h ]|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)