use strict;
my $str = '|dart24356- shows [ 8d 9h ]|
|dart24356- shows [ Kd Kh ]|
|dart24356- shows [ Qc Ac ] |
|ABC- shows [ 8d 9h ]|
|ABC- shows [ Qd 9h ]|';
my $regex = qr/^.*\[.*[KQA].*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";